Reply to this topicStart new topicStart Poll

> Использование internet explorer 8, как с этим жить?
Sergey_758
Отправлено: Окт 5 2016, 18:29
Quote Post


Активный пользователь
***

Группа: Пользователи
Сообщений: 376
Пользователь №: 2
Регистрация: 1-Марта 14
Статус: Offline

Репутация: 4




И так, не успел пройти релиз, а уже посыпались первые багофиксы...
👿
Во время использования программы некоторые из Вас столкнулись с проблемой возникающей при добавлении координат точки на карте, а точнее при установке маркера в нужном месте карты по нажатию правой клавиши мышки. В место отображения контекстного меню из трех пунктов для отметки точки, у Вас выскакивает стандартная менюшка internet explorer. Дело в том, что разные версии IE воспринимают одну и ту же команду по разному, и тут, к сожалению, ничего не сделаешь. Тем более, напомню, что для полноценной работы программы FWS, на компьютере, где она используется, должен быть установлен internet explorer 10 или выше. Это не моя прихоть, а скорее, суровые требования реальности. Дело в том, что для определения координат точки на карте (или геокодирования) используется библиотека GMLib, разработчики которой (собственно как и MicroSoft) давно отказались от поддержки windows XP, а в месте с ним и internet explorer 8. Но, так как в большинстве подразделений до сих пор активно используется именно эта ОС мы пришли к дилемме. Т.е. использовать более старые версии данной библиотеки в программе я не могу по тому, что они не соответствуют API поставщиков картографических данных, а перейти к новым версиям, означает ограничить всех пользователей которые используют IE 8.

В связи с этим было принято решение добавить в программу "заплатку". (да, именно "заплатку", по другому это не назовешь) которая могла бы дать возможность использовать IE 8. Суть этой заплатки заключается в том, что начиная с версии 4.0.2.9 программы FWS контекстное меню вызывается на карте как нажатием правой клавиши мишки (для IE 10 и выше), так и нажатием левой клавиши мишки с одновременно зажатой клавишей Ctrl (неважно левой или правой) на клавиатуре (для IE 8 и 9).

Кроме того, данное обновление программы пройдет не совсем гладко и для его корректной установки необходимо, что бы у Вас уже была установлена версия 4.0.2.8.
PMEmail PosterICQ
Top
0 Пользователей читают эту тему (0 Гостей и 0 Скрытых Пользователей)
0 Пользователей:

Topic Options Reply to this topicStart new topicStart Poll


 


Мобильная версия